Browser

Working with Files and Folders

Edit

You can edit any file on the server using your preferred application. See Edit Files.

Create new Folder or File

Use File → New Folder… (macOS ⇧⌘N Windows Ctrl+Shift+N) or File → New File… (macOS ⌘F Windows Ctrl+Shift+F) to create a new folder or file on the server.

Move or Duplicate Files and Folders

You can move files in the browser as you would in the Finder.app/ Explorer using drag and drop. Use the modifier key on macOS or the Ctrl key on Windows to duplicate files. If connected to the same server, you can also move files between different browser windows.

The following protocols allow duplicating files on the server without downloading and uploading but copying in place:

To move a file, use Edit → Cut (macOS ⌘X Windows Ctrl+X) followed by Edit → Paste (macOS ⌘V Windows Ctrl+V). To duplicate a file, use Edit → Copy (macOS ⌘C Windows Ctrl+C) followed by Edit → Paste (macOS ⌘V Windows Ctrl+V).

Copy Files and Folders to Different Server

You can copy files between arbitrary servers when connected to with two open browser windows. Drag files from one browser to the other to transfer files between servers.

Send Command

Rename a File or Folder

Select the file in the browser and press the Return key. Type the new name and press Return again to exit the editing mode. You can also rename files by choosing File → Info (macOS ⌘I Windows Alt+Return) or press the Get Info toolbar button. Simply enter the new name in the very top field. The field must lose focus (e.g. by hitting Return or Tab) to commit the filename change.

Send Command

Info Window

Select the file in the browser and choose File → Info (macOS ⌘I Windows Alt+Return) to display detailed attributes of a file in a tool window. It allows to change permissions, manage content distributions for cloud services, and settings specific to the Amazon S3 service.

Quick Look

macOS only

You can toggle Quick Look in a Cyberduck browser for any file using Space Bar. A preview is rendered depending on a Quick Look Plugin available on your system for the given file type. Many file types like different image formats can be previewed with the bundled plugins in OS X and HTML is even rendered in the Quick Look preview panel.

Send Command

Open or Copy HTTP URL

See bookmark Web URL configuration for HTTP URLs. You can select multiple files to open/copy all URLs.

  • Open Web URL: The Web URL can be found in the File → Open URL menu and as an optional toolbar item in the browser window. Use View → Customize Toolbar… to add the Open in Browser button to your default browser toolbar.

  • Copy Web URL: The Web URL can be found in the Edit → Copy URl menu.

Share Files

Refer to Share.

Open in Terminal

Refer to Open in Terminal.

Folder Icon Badges

Folder icons are badged for paticular access permissions.

Send Command

Folder with no permission to access.

Send Command

Folder with read-only permissions. Uploading or editing files to this folder is not possible.

Send Command

Drop Folder where you can only upload files to but are not allowed to view its content.

Versions

You can view all revisions of a file in the browser by choosing View → Show Hidden Files. The following protocols support versioning

Revert

To revert to a previous version and make it the current, choose File → Revert.

Activity

Use Window → Activity (macOS ⌘0 Windows Ctrl+0) to toggle the activity window. It lists the currently running background tasks at the top and all queued activities subsequently.

Send Command

Problems

Special Characters Such as Umlaute

If characters aren’t displayed correctly in the browser, try to change the character encoding used. See View → Text Encoding or edit the bookmark Encoding setting. Try UTF-8 (the default), ISO-8859-1, and Windows-1252.

The Folder Size isn’t Displayed Correctly

This is not the size of its content but the size of the folder itself. Use File → Info (macOS ⌘I Windows Alt+Return) to calculate the size of all contained files recursively.

Preferences

General → Browser → Save Workspace

Restore browser sessions that were left open when the application was last closed.

General → Browser → Open new browser window on startup

Open new browser window after application launch.

Browser → General → Show Hidden Files

Display files in the browser that start with . and previous revisions (S3). Use View → Show Hidden Files to toggle the mode of a current browser window.

Browser → General → Info window always shows current selection

Use only one Info window which updates with the selection change in the browser. If unchecked, open multiple Info windows to compare files.

Hidden Preferences

Adjust the Browser Font Size

A hidden configuration option.

defaults write ch.sudo.cyberduck browser.font.size 18

Duplicate Filename Format

A hidden configuration option. Define a different format using

defaults write ch.sudo.cyberduck browser.duplicate.format "{0} ({1}){2}"

where the plaseholders will be replaced with

  • {0} with the base filename

  • {1} with the timestampof the file

  • {2} with the extension in the format .extension if present in the original filename.

Warning Before Renaming or Moving Files

A hidden configuration option. A confirmation is shown before renaming or moving files.

defaults write ch.sudo.cyberduck browser.move.confirm true

Re-Enable File Listing Limit Prompt

A hidden configuration option can re-enable the file listing limit prompt after dismissing it with enabled Always checkbox.

Open Terminal.app and execute the command

defaults delete ch.sudo.cyberduck browser.list.limit.directory

and the command

defaults delete ch.sudo.cyberduck browser.list.limit.container